D-Link DSM-520 Firmware Upgrade?

<1 min read

As anybody seen the D-Link DSM-520 firmware upgrade that was promised on October 4th?

Nothing on the ftp site, yet.

Comments

10 (Closed)

Zeb

Oct 16, 2007

Looks like it went out last night.

Problem however, is that the ActiveTV software on their support website doesn't install on my Windoes XP Pro.

I called support and they confirmed they had the same problem.

I'm in the dark as to what's going on.

Great product, but their customer service stinks!

Erik C. Thauvin

Oct 17, 2007

Thanks for info.

ActiveTV seems to work fine under Windows Vista, although you're not missing much. It's pretty crappy overall.

At least the 1.05 firmware appears to be working much better than 1.04 did.

E.

Zeb

Oct 17, 2007

Ah.

Vista!

You would have thought they'd release something that's for XP too given the user base.

Any idea what "features" come with 1.05?

I see they finally put in a feature that when you stop a video, you can return to where you left off.

That's nice!

Erik C. Thauvin

Oct 17, 2007

I haven't notice anything new, yet, except for the ActiveTV; but more importantly, it fixes the video freezing problems a lot of us were experiencing with 1.04.

I found this post on the AVS forum that lists some of the problem that were fixed.

E.

John Hall

Oct 23, 2007

I was not able to hear music files when using the HDMI connection with v1.04.

I called support and they said "you should be able to do that"... that was their answer.

I just now updated the firmware to v1.05 but have to reconnect the HDMI to test this on my HD TV.

Is anyone else using the HDMI connection with this unit and can share their experience with it?

John

Erik C. Thauvin

Oct 23, 2007

I'm using HDMI. I didn't have the problem you described with sound in 1.04. Movies would simply stop or stall after a few minutes.

No problems with 1.05, so far.

E.

Erik C. Thauvin

Oct 25, 2007

I did discover a couple of issues... First, I can't view any photos. Second, the Photo home screen option takes me to my videos, the Video home screen option takes me to my photos.

I confirmed that it is not a problem with my NAS (LaCie Ethernet Disk mini) Media Server as it still works like it should on my DSM-320RD in the bedroom.

E.

sandeep vahi

Nov 6, 2007

Hi

I am tired trying to get my Dlink DSM 520 working. it hangs when I fast forward/ Rewind, please does anyone has a solution to it.

Terry Olsen

Nov 20, 2007

Everything was working fine with 1.04. I had no problems. But it automatically upgraded to 1.05 and now my videos constantly freeze. It'll freeze 3-5 times during a 90 minute movie. I have to push the stop button and then re-start it. Luckily it re-starts where it froze, but it's annoying as heck. Is there any way to downgrade back to 1.04?

Erik C. Thauvin

Nov 20, 2007

Terry, look at erik.thauvin.net…

E.